NH3 Anhydrous bar with flow issues? Try this fix

by Chris Saxe, Assumption, IL 

I received a  call today about a JD NH3 2510H ammonia bar with a Raven control system that was not getting flow to the applicator.   I walked the operator through the energize system check, then confirmed the settings and it was getting the correct speed. I then verified that the implement switch was working and the operator could also manually open the Raven valve.  The operator said the rate was bouncing all over the place, but he was still was not getting any flow.   The operator was pulling double tanks and one was 50% full and the other tank was empty.   A rate level that fluctuates wildly up and down is often the sign of an empty tank.   I then directed the operator to shut off the empty tank,  which was allowing vapor to spin the flow meter.   I also asked him to shut off the second tank that was 50% full and then to open the valve slowly.  The excess flow valve snapped shut on one tank when both tanks were at 50% so he continued to run until one tank went empty. By shutting off the tank and opening the valve slowly,  it allowed the excess flow valve in the withdraw valve to reopen.  He started running again but said it still didn’t work.  At that point,  the entire bar was drained empty so I told him to keep going and it charged the bar and it then went back to working perfectly.  Tank % gauges are known to stick, so if you have a similar issue where everything on the monitor and on the bar seem ok, have the operator shake the tank to see if it feels full or if float gauge bounces.  The gauge may be broken or stuck in place.  Be safe out there.  NH3 is dangerous stuff.

Sloan Support is written by the product support team at Sloan Implement, a 20 location John Deere dealer in Illinois and Wisconsin.   Learn more at www.sloans.com